Current situation regarding the server

Discussion in 'News' started by Looka, Sep 30, 2016.

By Looka on Sep 30, 2016 at 12:45 PM
  1. Looka

    Looka Owner | Developer
    Staff Member Owner

    Jun 14, 2016
    Likes Received:
    Hello players of drugrun!

    As most of you know there have been issues logging into the server lately. The admin team has been working on hard resolving these errors without success.

    UPDATE 4 Oct 2016:
    The issues still persist, we can't seem to find the source and have confirmed it's not DrugRun but something in the network of our current host. This means we have to switch hosts again.
    DrugRun is moving back to OVH this week. New location: Montreal, USA. Exact time will be announced within the next 48 hours.

    The server has been working great the past couple of weeks, performance tweaking made it work at a stable 20TPS(Ticks per second). However, somehow something changed a couple of days ago(we still do not know what caused this) which causes errors such as "Outdated server I'm still on 1.9.4", "Authentication servers are down. Please try again later, sorry!", time outs and connection throttling. We've investigated the entire server, tried different server IP's, plugins, cache wipes, databases, multiple re-installs and other things. The fact is that we haven't found a pattern in the error messages yet.

    Today we'll be testing out each plugin one by one and try to trace back the errors. Of course we also want the server to be up and running again as fast as possible due to hosting costs, current running ads which cost us a lot of money and players.

    We recommend waiting out until the issues are resolved. Player data, worlds, economy will NOT be reset! Do not worry about that!

    We hope to fix the issues soon and that you can all be playing on drugrun again!

    If you think you may know what causes these issues or just have questions feel free to reply to this thread(We've checked a ton of stuff already though).

    See you soon, DrugRun staff team.
    #1 Looka, Sep 30, 2016
    Last edited by a moderator: Oct 4, 2016
    Panda likes this.


Discussion in 'News' started by Looka, Sep 30, 2016.

    1. Flavour
      This did start happening after we switched to essentialsX in the quest to go lightweight.. Maybe that could be it?
    2. Flavour
      I know it's a lot of work, but maybe put a backup from 5 days ago on a temp ip. If that doesn't have auth issues, then maybe we could just bring updated player/world/region data to that server?

      And the outdated I'm still on 1.9.4 seems to only happen (as I've noticed) when the server is booting up. It loads the whole protocol hack last. Other times I have not noticed or received that error
    3. maxito43
      After spending about 8 hours on trying to fix the issue, thinking it had to do with a plugin, we just found out that when we run a vanilla server on a different port, we encounter the same issues. It's not related to our server, it's something on our dedicated server or on the network. Investigation continues...
      Webbey0828 likes this.
    4. gourgha
      Have you tried turning it off and on again ?
    5. Flavour

      No :(
    6. Jawanamakeout
      Does the server host allow you to configure firewall rules/exceptions? If so, you may need to manually unblock or allow connection to the auth servers. I think its an link.

Share This Page